Introduction

Getting started

To build cssed plugins You'll need some files in the cssed source code, and a development environment to compile C code, with GTK+2 and GLib 2 libraries installed.

This document does not describe how to set up your environment. If you cannot set up it yourself, then this document is not for you.

The required file to build cssed plugins is plugin.h, and eventually others depending on the plugin's needs.

Who is this for ?

This documentation is written for developers fluent in C language with knoweledge of GTK and GLib libraries who want to extend cssed.

You'll need - part of - cssed's source code , and a development environment to compile C or C++ code, with GTK+2 and GLib 2 libraries installed.

Cssed plugins can be built on:

You can donload cssed from http://cssed.sourceforge.net

Warning:
This API is a draft as it's sure it will change in next releases, if you use it take into account that you must check for changes on new releases of cssed, even while we ensure a compatibility layer with deprecated functions will exist.

[ Main Page | Next ]

Back to Index

This documentation is © Iago Rubio Sanfiz, 2004